re = /\([^+]*\)|\(-?\d+\+-?\d+\)/m
str = '[-4,1]+[-7,1]*([3,5]-([-1,2]*[4,5]-[0,2]))+(3+4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end