$re = '/\([^+]*\)|\(-?\d+\+-?\d+\)/m';
$str = '[-4,1]+[-7,1]*([3,5]-([-1,2]*[4,5]-[0,2]))+(3+4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);