$re = '/(?:.*(?:\r?\n)+){2}age(?:.*(?:\r?\n|$)+){3}/m';
$str = ' Pratap
pandey
age
25
student';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);