// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:.*(?:\r?\n)+){2}age(?:.*(?:\r?\n|$)+){3}").unwrap();
let string = " Pratap
pandey
age
25
student";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}