re = /(?:.*(?:\r?\n)+){2}age(?:.*(?:\r?\n|$)+){3}/m
str = ' Pratap
pandey
age
25
student'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end