#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)submitted by .+? ([^\s,]+)(?:,? (?:[JS]r\.?|Esq\.|III?|IV))? :"
Local $sString = "The following records request has been submitted by Bryan Trummer :" & @CRLF & _
"The following records request has been submitted by Ray Parker Jr. :" & @CRLF & _
"The following records request has been submitted by William Stanley Preston, Esq. :" & @CRLF & _
"The following records request has been submitted by Marshall Bruce Mathers III :" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")