// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)submitted by .+? ([^\s,]+)(?:,? (?:[JS]r\.?|Esq\.|III?|IV))? :").unwrap();
let string = "The following records request has been submitted by Bryan Trummer :
The following records request has been submitted by Ray Parker Jr. :
The following records request has been submitted by William Stanley Preston, Esq. :
The following records request has been submitted by Marshall Bruce Mathers III :
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}