# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[url\(\K[^()]+(?=\)])/$1/gm;t' <<< "[url('example')]"