re = /\[url\(\K[^()]+(?=\)])/m
str = '[url(\'example\')]'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result