const regex = /\[url\(\K[^()]+(?=\)])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[url\\(\\K[^()]+(?=\\)])', 'gm')
const str = `[url('example')]`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);