#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*u)(?=.*e)(?=.*a)(?=.*p)(?=.*s)(?!.*t)(?!.*r)(?!.*c)(?!.*k)(?!.*f)(?!.*i)(?!.*l)(?!.*d)(?!.*j)(?!.*m).[^u][^ae][^p][^s]$"
Local $sString = "track" & @CRLF & _
"field" & @CRLF & _
"ausep" & @CRLF & _
"useap" & @CRLF & _
"pause"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")