import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*u)(?=.*e)(?=.*a)(?=.*p)(?=.*s)(?!.*t)(?!.*r)(?!.*c)(?!.*k)(?!.*f)(?!.*i)(?!.*l)(?!.*d)(?!.*j)(?!.*m).[^u][^ae][^p][^s]$";
final String string = "track\n"
+ "field\n"
+ "ausep\n"
+ "useap\n"
+ "pause";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}