re = /^(?=.*u)(?=.*e)(?=.*a)(?=.*p)(?=.*s)(?!.*t)(?!.*r)(?!.*c)(?!.*k)(?!.*f)(?!.*i)(?!.*l)(?!.*d)(?!.*j)(?!.*m).[^u][^ae][^p][^s]$/m
str = 'track
field
ausep
useap
pause'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end