package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\{[^{}]*\}\}`)
var str = `the city of {{c2::Canberra}} was founded in {{c1::1}913}}, which was a long time ago.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}