re = /\{\{[^{}]*\}\}/m
str = 'the city of {{c2::Canberra}} was founded in {{c1::1}913}}, which was a long time ago.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end