$re = '/\{\{[^{}]*\}\}/m';
$str = 'the city of {{c2::Canberra}} was founded in {{c1::1}913}}, which was a long time ago.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);