#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(无|否认)(既往)?[^,。,.]{2,6}过敏史"
Local $sString = "患者既往体质尚可,否认有“高血压、糖尿病、冠心病”等慢性病病史,否认心、肝、脑、肺、肾“等重大脏器疾病史,否认”肝炎、肺结核等传染病史,否认其他重大手术及外伤史,否认输血及中毒史,呋喃唑酮过敏史,过敏表现:皮疹瘙痒、全身浮肿,否认食物药物过敏史"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")