import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\/)[\\d\\/]*$(?<!\\/)";
final String string = "122434\n"
+ "34///343\n"
+ "43/4333333\n"
+ "4/3/4/555/322/4\n"
+ "/432/343\n"
+ "122/323/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}