$re = '/^(?!\/)[\d\/]*$(?<!\/)/m';
$str = '122434
34///343
43/4333333
4/3/4/555/322/4
/432/343
122/323/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);