#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"17"\s*:\s*\{[^}]*\}"
Local $sString = "}" & @CRLF & _
""17" : {" & @CRLF & _
" "columnId" : 17," & @CRLF & _
" "columnName" : "id"," & @CRLF & _
" "value" : "1299:;6775"" & @CRLF & _
"}," & @CRLF & _
""19" : {" & @CRLF & _
" "columnId" : 19," & @CRLF & _
" "columnName" : "HelloWorld"," & @CRLF & _
" "value" : "Test 2.:;34147"" & @CRLF & _
"}," & @CRLF & _
""21" : {" & @CRLF & _
" "columnId" : 21," & @CRLF & _
" "columnName" : "Testing"," & @CRLF & _
" "value" : "Test"" & @CRLF & _
"}" & @CRLF & _
""17" : {" & @CRLF & _
" "columnId" : 17," & @CRLF & _
" "columnName" : "id"," & @CRLF & _
" "value" : "1299:;6775"" & @CRLF & _
"}," & @CRLF & _
""19" : {" & @CRLF & _
" "columnId" : 19," & @CRLF & _
" "columnName" : "HelloWorld"," & @CRLF & _
" "value" : "Test.:;34147"" & @CRLF & _
"},"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")