// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"17"\s*:\s*\{[^}]*\}"#).unwrap();
let string = "}
\"17\" : {
\"columnId\" : 17,
\"columnName\" : \"id\",
\"value\" : \"1299:;6775\"
},
\"19\" : {
\"columnId\" : 19,
\"columnName\" : \"HelloWorld\",
\"value\" : \"Test 2.:;34147\"
},
\"21\" : {
\"columnId\" : 21,
\"columnName\" : \"Testing\",
\"value\" : \"Test\"
}
\"17\" : {
\"columnId\" : 17,
\"columnName\" : \"id\",
\"value\" : \"1299:;6775\"
},
\"19\" : {
\"columnId\" : 19,
\"columnName\" : \"HelloWorld\",
\"value\" : \"Test.:;34147\"
},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}