using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""17""\s*:\s*\{[^}]*\}";
string input = @"}
""17"" : {
""columnId"" : 17,
""columnName"" : ""id"",
""value"" : ""1299:;6775""
},
""19"" : {
""columnId"" : 19,
""columnName"" : ""HelloWorld"",
""value"" : ""Test 2.:;34147""
},
""21"" : {
""columnId"" : 21,
""columnName"" : ""Testing"",
""value"" : ""Test""
}
""17"" : {
""columnId"" : 17,
""columnName"" : ""id"",
""value"" : ""1299:;6775""
},
""19"" : {
""columnId"" : 19,
""columnName"" : ""HelloWorld"",
""value"" : ""Test.:;34147""
},";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}