import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:e(?:p(?:isode)?)?|x)?\\s*(\\d{2,3})\\b";
final String string = "Terkel in Trouble 2004\n"
+ "eisode12\n"
+ "episode12\n"
+ "e12\n"
+ "ep12\n"
+ "EP999 this is x888\n"
+ " 234\n"
+ "234";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}