re = /\b(?:e(?:p(?:isode)?)?|x)?\s*(\d{2,3})\b/i
str = 'Terkel in Trouble 2004
eisode12
episode12
e12
ep12
EP999 this is x888
234
234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end