use strict;
my $str = 'Terkel in Trouble 2004
eisode12
episode12
e12
ep12
EP999 this is x888
234
234';
my $regex = qr/\b(?:e(?:p(?:isode)?)?|x)?\s*(\d{2,3})\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}