$re = '/^(?:https?:\/\/)?(?:www\.)?\w+\.[a-z]{2,6}$/m';
$str = 'http://example.com
http://www.example.com
https://example.com
https://www.example.com
www.example.com
example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);