re = /^(?:https?:\/\/)?(?:www\.)?\w+\.[a-z]{2,6}$/m
str = 'http://example.com
http://www.example.com
https://example.com
https://www.example.com
www.example.com
example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end