// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?:\/\/)?(?:www\.)?\w+\.[a-z]{2,6}$").unwrap();
let string = "http://example.com
http://www.example.com
https://example.com
https://www.example.com
www.example.com
example.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}