package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^( +)([-+~]\s)(.*)(\s=\s|\s->\s|<<|\{|\(known after apply\)| {2,}[^ ]+:.*)(.*)`)
var str = ` - severity = warn`
var substitution = "$2$1$3$4$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}