re = /^( +)([-+~]\s)(.*)(\s=\s|\s->\s|<<|\{|\(known after apply\)| {2,}[^ ]+:.*)(.*)/m
str = ' - severity = warn'
subst = '$2$1$3$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result