const regex = new RegExp('^( +)([-+~]\\s)(.*)(\\s=\\s|\\s->\\s|<<|\\{|\\(known after apply\\)| {2,}[^ ]+:.*)(.*)', 'gm')
const str = ` - severity = warn`;
const subst = `$2$1$3$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);