#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^,]*), ?([^ ]*) ([^ ]*) ([^ ]*) (\d*.?\d*)"
Local $sString = "Collins Farm, 43900 tomatoes 0.67 29413" & @CRLF & _
"Bart Smith Farms, 34910 cassavas 0.99 34560.9" & @CRLF & _
"Allen Farms, 117 coconuts 0.54 63.18"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")