const regex = /([^,]*), ?([^ ]*) ([^ ]*) ([^ ]*) (\d*.?\d*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^,]*), ?([^ ]*) ([^ ]*) ([^ ]*) (\\d*.?\\d*)', 'g')
const str = `Collins Farm, 43900 tomatoes 0.67 29413
Bart Smith Farms, 34910 cassavas 0.99 34560.9
Allen Farms, 117 coconuts 0.54 63.18`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}