re = /([^,]*), ?([^ ]*) ([^ ]*) ([^ ]*) (\d*.?\d*)/
str = 'Collins Farm, 43900 tomatoes 0.67 29413
Bart Smith Farms, 34910 cassavas 0.99 34560.9
Allen Farms, 117 coconuts 0.54 63.18'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end