#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*#\h*(2020.*)([\s\S]*?(?:(?=(^\h*#\h*2020.*))|\z))"
Local $sString = "# Title" & @CRLF & _
"" & @CRLF & _
"# 2020-01-01" & @CRLF & _
"" & @CRLF & _
"Multi-line content" & @CRLF & _
"goes here" & @CRLF & _
"" & @CRLF & _
"# 2020-01-02" & @CRLF & _
"" & @CRLF & _
"Other multi-line content" & @CRLF & _
"goes here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")