$re = '/^\h*#\h*(2020.*)([\s\S]*?(?:(?=(^\h*#\h*2020.*))|\z))/m';
$str = '# Title
# 2020-01-01
Multi-line content
goes here
# 2020-01-02
Other multi-line content
goes here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);