re = /^\h*#\h*(2020.*)([\s\S]*?(?:(?=(^\h*#\h*2020.*))|\z))/m
str = '# Title
# 2020-01-01
Multi-line content
goes here
# 2020-01-02
Other multi-line content
goes here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end