package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\([^()]*\)\s*`)
var str = `This is a string (here is a text to remove), and here is a text not to remove`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}