re = /\s*\([^()]*\)\s*/
str = 'This is a string (here is a text to remove), and here is a text not to remove'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end