$re = '/\s*\([^()]*\)\s*/';
$str = 'This is a string (here is a text to remove), and here is a text not to remove';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);