package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^0-9][^0-9][^0-9][0-9][A-Za-z0-9][0-9][0-9])`)
var str = `:-$8456
Â5x55
"£¥5789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}