re = /^([^0-9][^0-9][^0-9][0-9][A-Za-z0-9][0-9][0-9])/m
str = ':-$8456
Â5x55
"£¥5789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end