using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$[0-9]{1,3}(\.[0-9]{2})?(?![0-9]|\.[0-9])";
string input = @"I have $400 in my bank account.
This TV costs $300
This TV costs $300.
""$45.3242"" or ""3499,391""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}