import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$[0-9]{1,3}(\\.[0-9]{2})?(?![0-9]|\\.[0-9])";
final String string = "I have $400 in my bank account.\n"
+ "This TV costs $300\n"
+ "This TV costs $300.\n\n"
+ "\"$45.3242\" or \"3499,391\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}