re = /\$[0-9]{1,3}(\.[0-9]{2})?(?![0-9]|\.[0-9])/m
str = 'I have $400 in my bank account.
This TV costs $300
This TV costs $300.
"$45.3242" or "3499,391"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end