package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\s*?\$[^=]+= *explode.*?)\);`)
var str = `$data = explode("|", $file[0]);
$xdata=explode("|", $xfile[1]);
$ydata = explode("|", $yfile[2]);
`
var substitution = "$1 ?? '');"
fmt.Println(re.ReplaceAllString(str, substitution))
}