import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*?\\$[^=]+= *explode.*?)\\);";
final String string = "$data = explode(\"|\", $file[0]);\n"
+ "$xdata=explode(\"|\", $xfile[1]);\n"
+ "$ydata = explode(\"|\", $yfile[2]);\n";
final String subst = "$1 ?? '');";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}