import Foundation
let pattern = #"^(\s*?\$[^=]+= *explode.*?)\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$data = explode("|", $file[0]);
$xdata=explode("|", $xfile[1]);
$ydata = explode("|", $yfile[2]);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 ?? '');"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)