const regex = /\d(?:\s?\d){13,}(?:\s?C)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?:\\s?\\d){13,}(?:\\s?C)?', 'gm')
const str = `"Hello test 1 23 45 678 901 234 C test test2"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}