$re = '/\d(?:\s?\d){13,}(?:\s?C)?/m';
$str = '"Hello test 1 23 45 678 901 234 C test test2"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);